Core i9 9900K+Z390 Designare Thunderbolt Mojave 10.14.5

Core i9 9900K+Z390 Designare Thunderbolt Mojave 10.14.5














Parts List
  • CPU: Intel i9 9900K
  • Motherboard: Gigabyte Z390 DESIGNARE (ThunderBolt)
  • GPU: Sapphire Radeon RX Vega 64 8GB
  • RAM: 2x 16GB Kingston HyperX 2666MHz
  • Case: Fractal Design Define R6
  • Storage: 1x 500GB 960 Evo, 1x 1TB WD Blue M.2 SATA, 2x 8TB HGST HDD, 1x WD 4TB HDD, 1x 3TB Hitachi HDD
  • Extras: NZXT Internal USB hub
    Sound Card: UAD X8 Thunderbolt Card (Apple Thunderbolt Cabel Bought additional)
Working
  • All case and motherboard USB 2 and 3 ports
  • iGPU
  • Dual Gigabit Ethernet
  • Both onboard Thunderbolt 3/USB 3.1 (tested with Sonnet eGPU enclosure and a Blackmagic eGPU with some interesting results:eGPUs have hotswap with the custom SSDT created by CaseySJ but cannot be used and are not properly recognizedeGPUs can be used WITHOUT the SSDT, but are detected as internal PCIBlackmagic Decklink 4K Extreme 12G works flawlessly with required drivers, hotswap and all)
  • Internal case USB hub
  • 3 Dell P2214H displays via GPU's DisplayPort (1 vertical monitor patched to rotate properly on boot)
Not working
  • Intel CNVi WiFi+Bluetooth card (could switch out for a BCM94331CD I have, but I don't really need WiFi+Bluetooth in macOS)
  • Occasional "couldn't allocate runtime area" problem on boot - solved by restarting the computer (looking into eliminating this altogether, but it hasn't come up so far since updating the install to the 18E2034 build and using the iMac19,1 SMBIOS)
  •  Fixed by changing the install to the 18E2034 build of 10.14.4 and using the iMac19,1 SMBIOS.
Notes
Guides used:
Vanilla install +

Instead of copying kexts to /L/E, I'm injecting them via Clover.

Thank you to all previous OPs who've documented their work and consequently made this build almost problem-free!