Audio Desk - GA-H97-HD3 - 4790K - HD4600 - Wifi - ATX


 24i/o MOTU Audio Desk
  Audio Desk - GA-H97-HD3 - i7-4790K - HD4600 - WiFi

Components

Apple Mac OS X Yosemite 10.10.2

GIGABYTE GA-H97-HD3 ATX Intel 1150 Motherboard
http://www.amazon.fr/dp/B00K872GHU

Motu 24i/o Core system PCI Express Audio Interface
http://www.musiciansfriend.com/pro-a...re-system-pcie

Intel Core i7-4790k Haswell Refresh Quad-Core Processor
http://www.amazon.fr/dp/B00KPRWAX8

Zalman CNPS8900 Quiet CPU Cooler
http://www.amazon.fr/dp/B0077POH8M/

Silverstone SOD02 SLIM SLOT-IN SATA DVD/CD Rewritable Drive
http://www.amazon.fr/dp/B004ULZ47Y/

Kingston HyperX Savage 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)
http://www.amazon.fr/dp/B00N9PVZ3O/

Rosewill/Jonsbo/LDLC/Cooltek ATX Trio Fan UMX1
http://www.amazon.fr/dp/B00KBRV0SS/

Corsair RM450 Modular Power Supply - Haswell Compatible
http://www.amazon.fr/dp/B00F4UYVZ6/

Samsung EVO850 250Gb SATA 6Gb/s 2.5" SSD Drive
http://www.amazon.com/dp/B00OAJ412U

Western Digital Blue 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive
http://www.amazon.fr/dp/B0088PUEPK/

TP-Link TL-WDN4800 PCIe WIFI Card 450MBPs
http://www.amazon.fr/dp/B007GMPZ0A/




Already Owned

NEC EA241WM 24" Flatscreen LCD Monitor 1920x1200
http://www.amazon.fr/dp/B00AINBC2O/

Apple USB Keyboard
http://www.amazon.fr/dp/B005DPEHHO/

Logitech USB Standard Mouse


Comments

I'm a hobbyist musician since ages now and running software like Ableton Live, Harrison Mixbus, Native Instruments Maschine and Komplete, and lots of hardware gear like MIDI devices, synthesizers and recording gear for real instruments like guitar, voice, field recordings and so on…

I'm feeling my second MacBook is more and more out daded for the hardware (2,4ghz core2duo, 4gb Ram and a Seagate Hybrid 7200RPM Drive), and also for the software (stuck with Lion on this hardware). Processor is sweating a lot when composing music with lots of audio files, midi connections and multiple VSTs thru Maschine within Ableton as a Host, or when rewiring audio channels virtually between live and mixbus (an ardour based analog style mixing console layer) with stuff like soundflower or jackOSx…

Time has come for a new system. I fist decided to get me a brand new MacBook Pro 15" i7 2,5ghz but the prices were so high, hardware so limited as for the options and expandability, and the mac pro line is out of my hobbyist range. Mac mini i7 from 2012 were interesting too, but also too limited for my needs…
The hackintosh idea was growing and growing, and since I discovered Tonymacx86 (and other sites) I felt that I was now able with all the useful help and tools available here, to buil the Hack of my dreams...

I just needed a simple build with the last gen hardware, no graphic card needed, only 2 PCI slots for wifi and my audio interface, and lots of RAM, CPU power. SSD for the system and main software, and a 7200rpm 1Tb HD for the samples, music and everything.

Got myself about a month picking parts with Tonymac's guide. The whole build is around 1100€, I got a good opportunity for the audio interface and its PCIe card that I could buy second hand for 550€.
For a matter of price and to compensate for the high price of the case, I ordered RAM not registered in the guide, but I knew this should be OK.

Same for the mobo, but I was a bit more itchy : I tried the HD3 version of the Gigabyte GA-H97 ATX motherboard because it had all I needed for PCI connections and expandability (up to 32GB ram, 2PCI and 2PCIe) for a cheaper price than the well known D3H version… I decided to give it a try, and all is good!


After a day building the hardware (case is really small for ATX gear…), I processed the Tonymac's Guide for installing Yosemite with MultiBeast, with a fresh copy of Yosemite 10.10.2 from the App Store (had to use a friend's younger MacBook than mine to be hardwarely able to download it).


1) Updated the Motherboard's BIOS with the brand new 8GB USB stick, using the Gigabyte's BIOS option to update the firmware from v5 to v6, as v7 was still a beta download.

2) Did the 8gb USB Yosemite install drive with UniBeast and Disk Utility as described in the guide

3) Bios configuration as in the guide for UEFI Intel 9 series motherboards, nothing special I can remember here. I disabled 'generate CPU states' as I read that it was not good for Haswell refresh processors.

4) Boot the installer and follow the guide's instructions until the first reboot after the installation. Then there was a kernel panic that froze the computer during boot and couldn't get to the OS.

I then rebooted with the USB stick and went in the Disk utility to repair the drive's permissions, and also I did format the 2nd drive, as I was there ^^

I know I also had an eye again into the BIOS but I can't remember if I changed anything at this stage…

Then I could boot into Yosemite

And load MultiBeast and build a working configuration with 3-4 trials for on-board sound and Ethernet port to be recognized by the system. Audio : ALC887/888b CURRENT (and not legacy that will not work with this mobo) for the sound drivers, and all I/Os are fully working (front panel and mobo's connectors), I was even able to make an aggregate device with all these I/Os ^^

Ethernet Network is good with RealtekRTL8111 v1.2.3.

I installed the USB3 drivers with multibeast, but this was an error. I had then to remove the GenericUSB kext and replace it with a modified one : https://bitbucket.org/Riz/os-x-...-2014-1016.zip using KextBeast. I guess if I didn't first install the USB3 drivers in multibeast, this would'nt been needed as I read 9 series motherboards have native usb3 drivers supported by Yosemite (info to be verified). The problem with multibeast's USB3 drivers was my external USB hard drive totally freezing the system... No problem now with RehabMan's driver.

The PCIe WIFI card was recognised as soon as it was installed and system booted.

I still didn't install the audio interface, I'm waiting for my order to arrive (by the end of March).

All USB ports are fully functional, as are the DVI-D and HDMI outputs, with 1920x1200 resolution on my 24" 16/10 monitor. The power button works like a charm on the front panel (no back power button on this case) with a blue led inside the tiny center hole, and the red led under it for the HD activity also works. I didn't try any sleep mode, and the system boots in only a few seconds…

The CD/DVD drive was fully functional as soon as installed too. Could install Native Instrument Komplete 9 and its 12DVDs of data with no problem.


I'm really happy all this build went quite nicely fluid, no big problems and all useful tips I could need to be found here quite easily with a little searching and reading.


-------------------------------------------------------------------------


Share this

Related Posts

1 comments :

comments
20 October 2015 at 00:51 delete This comment has been removed by a blog administrator.
avatar